Problem
Unable to click "Refresh Device" in license manager to update a license due to a proxy server blocking communication to the exterro (AccessData) license server.
(Possible Cause of Error 105 in License Manager.)
Resolution
Note: This configuration option is a feature of CodeMeter made by WiBU. If you have trouble with this configuration, WiBu support will be your contact for troubleshooting, not Exterro Support. https://www.wibu.com/us/support/customer.html
Option 1: Use the CodeMeter WebAdmin to configure the Proxy Server information.
- Open a web browser on the same computer/server where CodeMeter is installed an enter this URL http://localhost:22352/configuration/proxy.html
OR - Open Code Meter and click File > WebAdmin
Option 2: Use the command line option to configure the Proxy Server information.
Navigate to this folder within a Command Prompt: C:\Program Files (x86)\CodeMeter\Runtime\bin
Use this syntax:
cmu32.exe --set-proxy "ServerName" --username xxxxx --password xxxxxx --port xxxx
Example:cmu32.exe --set-proxy "MyProxy.exterro.com" --username "john.doe" --password "mypassword" --port 90
Cause
A proxy server on the customer envrionment is blocking two way communication with the license server at exterro.