Problem

Unable to connect to one or more ADG databases (typically Infrastructure / eDiscovery). 


Logs report "The target principal name is incorrect. Cannot generate SSPI context."

 

Resolution

Login as your Service Account on your main adg.weblabselfhost.exe server.

Download the Microsoft Kerberos Configuration Manager for SQL Server.

Install on to your main adg.weblabselfhost.exe server (take note of the Install directory).

Go to the Install directory and Connect to your SQL instance.

Click onto the SPN tab.

Check the Status column. If there is a mismatch and the required SPN is not associated correctly in Kerberos you will see a 'Fix' option in the far right column.

Click Fix, read the warning and proceed with caution.


Note: There are extensive instructions on how to use the tool on the Microsoft Download site (under Install Instructions).

 

Cause

SPN was not associated with your Service Account.