Problem
AD integration is not working and you are effectively "locked out" of FTK Central.
Resolution
Option 1:
- Use the FTK Central Configuration Tool to change the Authentication Method to Forms (Internal Authentication only)
- Restart the exterroweblabselfhost service
- login as local admin (if you do not know what to use, reach out to exterro support for assistance in looking up the user in the database)
- Once logged into FTK Central, verify Active Directory configuration according to this article: Active Directory Authentication - FTK Central
- Use the FTK Central Configuration Tool to change the Authentication Method to your preferred Active Directory log on method
- Restart the exterroweblabselfhost service
- Ensure you can now log in using Active Directory
Option 2:
- Edit the ADG.weblabselfhost.config file found at C:\Program Files\AccessData\Forensic Tools\<version>\bin
- find the key for <add key="UseAD" value=''>
- Change the value to 0 and save
- Restart the exterroweblabselfhost service
- login as local admin (if you do not know what to use, reach out to exterro support for assistance in looking up the user in the database)
- Once logged into FTK Central, verify Active Directory configuration according to this article: Active Directory Authentication - FTK Central
- Change the key above back to the value it was previously and save
- Restart the exterroweblabselfhost service
- Ensure you can now log in using Active Directory
Cause
AD or LDAP server is off line, moved, changed name/address, or otherwise broke