Problem
Any jobs submitted via the Bulk Actions menu stay at the "Submitted" status in the Work List.
Resolution
On all involved machines:
- Log in to Windows using your Summation service account
- Open the Services snap-in (services.msc)
- Stop all AccessData services
On the machine with "WCF Services" and "Processing Services":
- Open Compute Management (compmgmt.msc)**
- Expand "Services and Application"
- Expand "Message Queuing"
- Expand "Private Queues"
- Delete all "accessdatagroup" and "asyncprocessingservices" queues (you may have to take ownership and modify Security permissions of the queues in order to delete them)
**You may be able to use the attached "DeleteAsyncQueues.ps1" PowerShell script to delete all the necessary queues. - Open Advanced System Properties (systempropertiesadvanced)
- Click "Environmental Variables"
- Under "User variables", double-click the "PATH" variable
- Make sure the path "C:\Program Files\AccessData\AsyncProcessingServices\bin" is at the very beginning of the "Variable value" field and click OK
- Under "System variables", double-click the "Path" variable
- Make sure the path "C:\Program Files\AccessData\AsyncProcessingServices\bin" is at the very beginning of the "Variable value" field and click OK
On all involved machines:
12. Reboot.
On the Summation Pro application server
13. Open a web browser from the application server and go to the following URL.
http://localhost/accessdatagroup/router.svc
Wait for the webpage to load completely. Then go the following URL.
http://localhost/asyncprocessingservices/import.svc
Wait for the webpage to load completely.
On the machine with "WCF Services" and "Processing Services":
14. Confirm the "AsyncProcessingAppPool" application pool (5.6.3 and older) or the "Async Processing Services" service (6.0 and newer) is started
If the above steps do not work, you may need to uninstall and reinstall the "WCF Services", making sure they are set use your Summation service account credentials.
NOTE: Steps 1 thru 13 above apply to Summation Pro version 5.6.3 and earlier.
Summation Pro Version 6.x and later do not have message queues and do not have the "bin" folder.
Cause
- The message queues are broken
- The environmental variables are causing the wrong dependencies to be called
- "WCF Services" and "Processing Services" were not installed correctly
- Async is not started