Problem
- Exchange Collections Fail immediately
- Other collections work fine
- System Log reports: "Error: Padding is invalid and cannot be removed."
Resolution
- Backup and delete all Exchange Data Source configuration records found in eDiscovery.dbo.MailServers
- Run script to reset eDiscovery Processing User permissions:
- Recycle all eDiscovery services.
- Manually add back all Exchange Data Source configuration records.
- Process a test collection.
- Execute Exchange collection test job.
Cause
Records in the database are invalid or have corrupt keys.