Problem

  1. Exchange Collections Fail immediately
  2. Other collections work fine
  3. System Log reports: "Error: Padding is invalid and cannot be removed."

 

Resolution

  1. Backup and delete all Exchange Data Source configuration records found in eDiscovery.dbo.MailServers
  2. Run script to reset eDiscovery Processing User permissions:
  3. Recycle all eDiscovery services.
  4. Manually add back all Exchange Data Source configuration records.
  5. Process a test collection.
  6. Execute Exchange collection test job.

 

Cause

Records in the database are invalid or have corrupt keys.