Problem

When trying to access any of the message queues via a browser (e.g. "http:\\localhost\AsyncProcessingServices/Import.svc") you may see the following error message.

Exception: System.Configuration.ConfigurationErrorsException

Message: Could not load file or assembly 'Database.dll' or one of its dependencies. The operating system cannot run . (Exception from HRESULT: 0x800700B6)

 

Resolution

1. Move the Async directory to the front of the two path variables (see image below).

2. Reboot the server.

 

Cause

The error indicates that the async website can not find the DLLs mentioned. This has to do with the environment paths. Possibly due to a bad path in the PATH environment variables. 

 

Applies To

AD Ediscovery 5.6.3 and earlier

Summation Pro 5.6.3 and earlier