Problem
AD eDiscovery or FTK Central email collection shows a hit count, but then later goes to "Failed" status.
System Log shows the following error:
Failed to add emails to PST. Failed to create instance of Redemption COM type: 'AccessDataRedemption.RDOSession'. [1]
Resolution
AD eDiscovery
- Confirm you've installed Outlook 2016 32-bit Professional Plus on the collections Work Manager machine.
- Open a command prompt.
- Change your current directory to the Work Manager installation folder (typically "[drive]:\Program Files\AccessData\eDiscovery\Work Manager")
- Issue the following command:
regsvr32 AccessDataRedemption.dll
- Try your collection again.
FTK Central
- Confirm you've installed Outlook 2016 32-bit Professional Plus on the FTK Central server.
- Open a command prompt.
- Change your current directory to the FTK Central installation folder (typically "[drive]:\Program Files\AccessData\Forensic Tools\<version>\bin")
- Issue the following command:
regsvr32 AccessDataRedemption.dll
- Try your collection again.
Cause
PSTBuilder relies on a locally installed instance of Microsoft Outlook 32-bit. When AD eDiscovery tries to call PSTBuilder to build the collected emails into a PST file, it crashes because the Work Manager component cannot talk to the Outlook 32 bit DLLs required for PST generation.