Problem
When restoring/attaching a case backup/archive it fails with error 103 and the FTK_log.txt shows the error "String was not recognized as a valid DateTime."
Resolution
On every machine:
- Close FTK
- Open Windows Region settings (intl.cpl)
- Make sure every option in the dialog is the same for all involved machines
For any backups/archives where the original case still exists:
- After correcting the Region settings to match all other machines, make a new backup of the case
- Restore the backup at the desired location
For any backups/archives whose original case no longer exists:
- Open the Map.xml from that backup in a text editor
- In the
section, look for
Cause
Your machines are not using the same region and date settings. This causes the box where you're restoring/attaching to try and fail to interpret dates according to its own region and date format settings.