Problem
When performing an extraction of an Apple mobile device, MPE+ may fail to connect to the device, extract data from the device, or parse data after extraction.
Error Message: An internal error has occurred in our data acquisition layer please contact support.
Resolution
Confirm that the Apple device and its operating system are supported. Here is a help article.
https://support.accessdata.com/hc/en-us/articles/203389529-List-of-supported-iOS-devices
If supported, then please see below.
- Ensure both "Apple Application Support" and "Apple Mobile Device Support" have been installed (these are installed with either the MPE Smartphone Driver or iTunes).
- In Device Manager, expand "Portable Devices".
- Look for any entry that says iPhone, iPad, or iPod.
- Right-click the iPhone, iPad, or iPod entry and click "Update Driver".
- Click "Browse my computer for driver software".
- Click "Let me pick from a list of device drivers on my computer".
- Click "Have Disk".
- Click "Browse" button.
- Browse to "C:\Program Files\Common Files\Apple\Mobile Device Support\Drivers" and select the appropriate INF file:
Windows x86: usbaapl.inf
Windows x64: usbaapl64.inf - Click "OK" and complete the installation.
- Confirm there's now an entry for "Apple Mobile Device USB Driver" under the category "Universal Serial Bus Controllers".
Cause
- The Apple device or its OS is not supported.
- The Apple Mobile Device driver did not install correctly.