Problem

Incorrect encoding can lead to several issues during import, including the following:

  • When starting an Import, the Field Mapping (Map Fields) dialog is blank with no fields shown.
  • After the import has started, you receive the error the error message "Error: Index was outside the bounds of the array."
  • After the import has started, you receive the error the error message "Error: Cannot be less than zero."
  • After the import has started, you receive the error the error message "Error: Sequence contains no elements."
  • Import completes successfully, but some fields have unexpected characters, such as "þ".

 

Resolution

1) Verify the load file encoding.

Using Notepad++, confirm the encoding is not UTF-8 without BOM. Any of the following are acceptable encoding:

  • UTF-8 with BOM (sometimes called UTF-8-BOM)
  • ANSI
  • ASCII

If you have Concordance/Relativity files, make sure that both files have the same encoding.

------------------------------------------------------------

Important:

In newer versions of Notepad++, the selection "UTF-8" is actually the unsupported UTF-8 without BOM, while the selection "UTF-8-BOM" is the supported UTF-8 with BOM.

If your version of Notepad++ offers "UTF-8" and "UTF-8 without BOM", you want "UTF-8".

If your version of Notepad++ offers "UTF-8" and "UTF-8-BOM", you want "UTF-8-BOM".

------------------------------------------------------------

2) Verify the delimiters are correct. 

Confirm your delimiters are put in correctly before clicking map fields.

 

Confirm you have the proper delimiter for your version, see below section.

3) Verify that all field headers are completely unique.

If you still cannot map fields even with the correct delimiters and encoding, check that you do not have duplicate headers.

4) Separate Web Server only: Confirm the "check file service" is set properly.

For environments where the Ediscovery/Summation Pro web server (MAP) is a different server from the application server, confirm the "check file service" is set properly on the MAP server. Here is a help link about that: Load File SSPI Error

Cause

When you click map fields here's what happens:

  • The file is opened and looks for the unique identifier in the first column based on the delimiters chosen

In 5.2.x - "Required document identifier column is missing" will populate in the system log

  • Docid

In 5.6.x

  • DocID
  • DocNumber
  • DocNo
  • BegDoc
  • BegDocID
  • BegBates
  • ID
  • ControlID
  • ControlNo
  • ControlNum
  • ControlNumber
  • CtrlID
  • CtrlNo
  • CtrlNum
  • CtrlNumber
  • BegNum
  • BegNumber
  • Bates
  • BatesNo
  • BegBatesNo
  • BegBatesNumber 
  • Identifier

Load files with an encoding of "UTF-8 without BOM" (screen shot from Notepad++ v6.7.7) is an unsupported type.