Problem

When attempting to process or export evidence, you receive the error messages “Failed to initialize progress tracking”, “Unable to connect to the database”, or "Invalid Username/password 0".

 

Resolution

FTK:

  1. Cancel the job that resulted in the errors
  2. Close FTK
  3. Open Task Manager
  4. Under the Processes tab, end ProcessingHost.exe and (if present) ADProcessor.exe
  5. Make sure the proper version of the Evidence Processing Engine is installed on any Distributed Process machines
  6. Open FTK and start the job again

Summation/eDiscovery:

  1. Open MSSQL Management Studio
  2. Click "New Query"
  3. Assign Application Administrator permissions to the EvidenceProcessingUser user by executing the following SQL query:

    INSERT INTO ADG.adg510.cmn_UserEntityRights (UserEntityRightsId, UserId, RoleId, EntityType, EntityId, Disallow) VALUES (ADG.adg510.nextvalue('cmn_UserEntityRights_PK_Seq'), (Select UserID from ADG.ADG510.cmn_users where UserName = 'EvidenceProcessingUser'), 100, 2 , NULL, 0);

  4. Open Summation and start the job again

 

Possible Causes

  • Multiple versions of the Evidence Processing Engine are installed on the same PC. This is because the Processing Hosts from the different Processing Engines can interfere with each other during processing.
  • The wrong version of the Distributed Processing Engine is installed.
  • The ProcessingHost.exe.config file has been misconfigured.  The Multi-Server Install Guide in the article below explains how to properly configure this file.
    https://support.accessdata.com/hc/en-us/articles/204311545-Install-Guide-Summation-Pro-5-6-1-Multi-Server
  • The EvidenceProcessingUser's permissions are corrupt