Symptoms
Site Server collections fail.
The expected Site Server is not listed as "Online" under System Configuration > Site Server > Health Metrics in FTK Central.
The adgselfhost log contains one or more error similar to the following:
- SiteServer internal error, MessageDetail: Server did not respond in a timely fashion. error code:FIPSCOMM_FAILED
- Could not connect to root instance (status: :FIPSCOMM_FAILED)
- Failure to connect to SiteServer
Resolution
- On the Site Server machine(s):
- Open Site Server Configuration (typically "C:\Program Files\AccessData\SiteServer\SS_Config.exe")
- Confirm that the certificates being used for Secure Communications exist
Note: All Site Servers (root & children) must have a local copy of the same certificates. - Make sure your certificates meet these requirements.
- View the certificates properties and make sure they have not expired. If they have, the client will need to generate or obtain new valid certificates to replace them.
- Restart the AccessData Site Server Service
- On the FTK Central Server:
- Confirm that the same certificates exist locally
- Confirm the Root Site Server is accessible over the expected port
- Use the FTK Central Configuration Tool to confirm the correct certificates and Site Server settings
- Restart the AccessData Self Host Service
- Log into FTK Central
- Verify the Site Server is listed as "Online" under System Configuration > Site Server > Health Metrics
Cause
This typically occurs when Site Server and/or Agent Certificates do not match or have expired, or firewall rules have changed.