Symptoms

Site Server collections fail.

The expected Site Server is not listed as "Online" under System Configuration > Site Server > Health Metrics in FTK Central.

The adgselfhost log contains one or more error similar to the following:

  • SiteServer internal error, MessageDetail: Server did not respond in a timely fashion. error code:FIPSCOMM_FAILED
  • Could not connect to root instance (status: :FIPSCOMM_FAILED)
  • Failure to connect to SiteServer


 

Resolution

  1. On the Site Server machine(s):
    1. Open Site Server Configuration (typically "C:\Program Files\AccessData\SiteServer\SS_Config.exe")
    2. Confirm that the certificates being used for Secure Communications exist
      Note: All Site Servers (root & children) must have a local copy of the same certificates.
    3. Make sure your certificates meet these requirements.
    4. View the certificates properties and make sure they have not expired.  If they have, the client will need to generate or obtain new valid certificates to replace them.
    5. Restart the AccessData Site Server Service
  2. On the FTK Central Server:
    1. Confirm that the same certificates exist locally
    2. Confirm the Root Site Server is accessible over the expected port
    3. Use the FTK Central Configuration Tool to confirm the correct certificates and Site Server settings
    4. Restart the AccessData Self Host Service
  3. Log into FTK Central
  4. Verify the Site Server is listed as "Online" under System Configuration > Site Server > Health Metrics

 

Cause

This typically occurs when Site Server  and/or Agent Certificates do not match or have expired, or firewall rules have changed.