Problem


Upon clicking "OK" in Enterprise Examiner Configuration, or in "Configure Agent Push" in AD Lab, you receive the following error:


Could not encrypt the private key.

 

Resolution

  1. Ensure you are specifying a PEM, encrypted P12, or ADP12 in the "Private Key" field
  2. Click "Apply"

 

Cause

You specified an unencrypted P12 for the "Private Key".