Problem
When attempting to create a document group in Summation/eDiscovery, job creation fails. The System Log reports "Error creating Document Group XXXX: A critical document group operation is in progress".
Resolution
- Wait for any active Import, Document Group creation, or Document Group deletion jobs to complete in your project (as shown in the Worklist)
- Try creating the new Document Group again
- If the issue persists, recycle services, ensuring the FTK Business Service is recycled.
Causes
Summation/eDiscovery allows only one job, that affects Document Groups in a given project, to run at a time. This prevents problems caused by potentially modifying a Document Group unintentionally.
- An Import or Document Group creation/deletion job is already running.
- A document group was deleted while it was still being created.
- Services were recycled during Document Group creation, leaving the database in a state where it thinks the job is still in progress.