Problem

You receive an error that "The server was unable to process the request" when adding a OneDrive connector in eDiscovery 6.3.  The System Log reports "Unauthorized" errors.

https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/69009876388/original/2017-12-06_13_49_15-G-Nl4l287BP7i4AhMWaMJEl4U1nJtvz1NRg34u_JUdRPu3Nnnn1KRSg0RDYhnwue5npY-buw7CcLPED1.png?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAS6FNSMY2XLZULJPI%2F20210926%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210926T165452Z&X-Amz-Expires=300&X-Amz-SignedHeaders=host&X-Amz-Signature=9f778e7e758fdd95ce79056d10fe5cfa87093cd65ef97bdc3776387f14157f6f

 

Resolution

  1. Log in to the Microsoft Application Registration Portal (https://apps.dev.microsoft.com/) with your organization’s OneDrive administrator’s credentials
  2. At “My Applications” select your application used for your OneDrive connector
  3. Re-copy the Application ID, ensuring there are no preceding or trailing spaces
  4. Under Application Secrets click “Generate New Password” to generate a new password, and copy it ensuring there are no preceding or trailing spaces
  5. Attempt to re-add the connector making sure to use the proper credentials to Authorize the connector

 

Cause

The "Application ID" or"OneDrive Client Secret" was entered incorrectly, or the wrong credentials were used to authorize the connector.