PROBLEM

In AD Enterprise, when going to Evidence > Add Remote Data, the message “Getting allowed agent data from Active Directory” appears and hangs.

https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/69009876214/original/2018-09-12_11_25_43-Chad_Cox__internal__s_Screen.png?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAS6FNSMY2XLZULJPI%2F20210926%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210926T165011Z&X-Amz-Expires=300&X-Amz-SignedHeaders=host&X-Amz-Signature=8d1814de0c2f699f1c729851ff82beaf3784dc330035086ccd386120989a349a

CAUSE

AD Enterprise is attempting to query Active Directory, but not getting a response or the results are too long.

SOLUTION

  1. Open regedit
  2. Navigate to "HKEY_LOCAL_MACHINE\SOFTWARE\AccessData\Enterprise"
  3. If the DWORD named "DisableAD" doesn't already exist, create it
  4. Give "DisableAD" the hex value "1"
    https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/69009876215/original/2018-09-12_11_41_19-Chad_Cox__internal__s_Screen.png?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAS6FNSMY2XLZULJPI%2F20210926%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210926T165011Z&X-Amz-Expires=300&X-Amz-SignedHeaders=host&X-Amz-Signature=799c5333d832e47ffb2b17cca3936f3f725d24b7d7ce0e557b93684847fc961f