Problem


Sometimes jobs are interrupted, incomplete, or failed improperly. Remnants from these actions may interfere with future processing attempts or impact performance. This article describes how to clear out those remnants.  


Resolution


  1. Close FTK completely. Stop the Exterro Self Host Service and if using Distributed Processing, stop the Distributed Processing Manager Service and the Distributed Processing Engine service on all the additional servers. 

  2. Open the task manager and make sure that FTK.exe is not still a running process and anything that starts with AD is not running (ADIndexer, ADLoader, ADProcesser, etc.). If any of those processes are still running, end their task.
  3. Delete the contents of the State (PM) and Temp folders 

    NOTE: In an environment utilizing additional distributed processing engines (DPE's), you will need to delete those folders on the primary server as well as all DPE servers.  


  4. Verify again in task manager that the AD tasks are not running. If any of them are running, kill their task again. If they promptly come back still, reach out to support@exterro.com. A support agent will need to assist you in clearing out additional job information within the database. 
  5. Restart all services you stopped in step 1 and verify behavior is now what you would expect. 



Cause


In some instances, the temporary files and processing status contained within these locations can trigger a job to restart or interfere despite the job being canceled.

Additional resources: