Problem

Errors such as "Actual file enumeration did not complete" or "Could not expand" appear in Disk Preview jobs in AD Enterprise file when using Distributed Processing.  

 

Prerequisite

  • Confirm the Distributed Processing Manager and all Distributed Processing Engines can reach the target over port 3999
  • Obtain copies of the private and public certificates used for your Agents

 

Resolution

On each machine with the Distributed Processing Engine, do the following:

  1. Copy the Agent certificate to a local folder, such as "C:\Program Files\AccessData\Certificates"
  2. Open regedit (as Administrator)
  3. Navigate to "HKLM\SOFTWARE\WOW6432Node\AccessData\Enterprise"
  4. Create a new Key called "Agent"
  5. Within "Agent", create the following String Values:
    1. "PushCert" - full path to the public certificate
    2. "CertPath" - full path to the private certificate
    3. "Port" - port used for the Agent (typically 3999)
  6. Open the Services snap-in (services.msc)
  7. Restart the "AccessData Processing Engine Service"

 

Cause

The Distributed Processing Engines must be aware of the Agent settings.