Problem
Clicking Evidence > Add Remote Data in Enterprise throws the error "An error occurred while retrieving Volatile Data" rather than showing the Add Remote Data dialog.
Resolution
- On the main Enterprise screen, go to Tools > Preferences.
- Delete the contents in the Private Key, Public Key, and Agent Port fields.
- Enter "3999" in the Agent Port field.
- Browse to your Private Key and Public Key.
- Click OK.
Cause
These settings are stored in the database as well as the local machine's registry (under "HKLM\SOFTWARE\WOW6432Node\AccessData\Enterprise\Agent"). If you connect Enterprise to an existing database, these settings may already be filled out, but they won't be added to the registry until you follow the steps above.