Problem

Clicking Evidence > Add Remote Data in Enterprise throws the error "An error occurred while retrieving Volatile Data" rather than showing the Add Remote Data dialog.

https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/69009875926/original/mceclip0.png?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAS6FNSMY2XLZULJPI%2F20210926%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210926T164223Z&X-Amz-Expires=300&X-Amz-SignedHeaders=host&X-Amz-Signature=510e11e0ca874532ed45171642ec42bca31209cfd613bc0ebb991baae8c6548f

 

Resolution

  1. On the main Enterprise screen, go to Tools > Preferences.
  2. Delete the contents in the Private Key, Public Key, and Agent Port fields.
  3. Enter "3999" in the Agent Port field.
  4. Browse to your Private Key and Public Key.
  5. Click OK.

Cause

These settings are stored in the database as well as the local machine's registry (under "HKLM\SOFTWARE\WOW6432Node\AccessData\Enterprise\Agent").  If you connect Enterprise to an existing database, these settings may already be filled out, but they won't be added to the registry until you follow the steps above.


Also if you attempt to update the certificates you may end up with these errors in the FTK_log.txt file located at %PROGRAMDATA%\AccessData\Products\Forensic Toolkit\<version>. Solution is the same.

20220519T131331.588 E [AgentPush.cpp:458]: AgentPush::InstallAgent(): Caught "The system cannot find the file specified.
 
", rv=0
20220519T131331.588 E [AgentPush.cpp:214]: AgentPush::InstallEnterpriseAgent(): Call to InstallAgent() Failed, rebooted=0